Fortinet Document Library

Version:

Version:

Version:


Table of Contents

Administration Guide

Download PDF
Copy Link

MAC addressed-based policies

MAC addresses can be added to the following IPv4 policies:

  • Firewall
  • Virtual wire pair
  • ACL
  • Central SNAT
  • DoS

A MAC address is a link layer-based address type and it cannot be forwarded across different IP segments. In FortiOS, you can configure a firewall address object with a singular MAC, wildcard MAC, multiple MACs, or a MAC range.

FortiOS only supports the MAC address type as source address for policies in NAT mode VDOM. When you use the MAC address type in a policy as source address in NAT mode VDOM, IP address translation (NAT) is still performed according to the rules defined in the policy. The MAC address type only works for source address matching. It does not have any association with NAT actions.

For policies in transparent mode or the virtual wire pair interface, you can use the MAC address type as source or destination address.

To configure a MAC address using the GUI:
  1. Go to Policy & Objects > Addresses and click Create New > Address.

  2. Enter a name.

  3. For Category, select Address.
  4. For Type, select Device (MAC Address).
  5. Enter the MAC address.

  6. Click OK.
  7. Go to Policy & Objects > Firewall Policy to apply the address type to a policy in NAT mode VDOM:
    1. For Source, select the MAC address you just configured.
    2. For Destination, select an address.
      Note

      In NAT mode VDOM, this address type cannot be used as destination address.

    3. Configure the other settings as needed.
    4. Click OK.
To configure a MAC address using the CLI:
  1. Create a new MAC address:
    config firewall address
        edit "test-mac-addr1"
            set type mac
            set macaddr 00:0c:29:41:98:88
        next
    end
  2. Apply the address type to a policy. In transparent mode or the virtual wire pair interface, this address type can be mixed with other address types in the policy:
    config firewall policy
        edit 1
            set srcintf "port2"
            set dstintf "port1"
            set srcaddr "test-mac-addr1" "10-1-100-42"
            set dstaddr "all"
            set action accept
            set schedule "always"
            set service "ALL"
            set logtraffic all
            set nat enable
        next
    end

MAC addressed-based policies

MAC addresses can be added to the following IPv4 policies:

  • Firewall
  • Virtual wire pair
  • ACL
  • Central SNAT
  • DoS

A MAC address is a link layer-based address type and it cannot be forwarded across different IP segments. In FortiOS, you can configure a firewall address object with a singular MAC, wildcard MAC, multiple MACs, or a MAC range.

FortiOS only supports the MAC address type as source address for policies in NAT mode VDOM. When you use the MAC address type in a policy as source address in NAT mode VDOM, IP address translation (NAT) is still performed according to the rules defined in the policy. The MAC address type only works for source address matching. It does not have any association with NAT actions.

For policies in transparent mode or the virtual wire pair interface, you can use the MAC address type as source or destination address.

To configure a MAC address using the GUI:
  1. Go to Policy & Objects > Addresses and click Create New > Address.

  2. Enter a name.

  3. For Category, select Address.
  4. For Type, select Device (MAC Address).
  5. Enter the MAC address.

  6. Click OK.
  7. Go to Policy & Objects > Firewall Policy to apply the address type to a policy in NAT mode VDOM:
    1. For Source, select the MAC address you just configured.
    2. For Destination, select an address.
      Note

      In NAT mode VDOM, this address type cannot be used as destination address.

    3. Configure the other settings as needed.
    4. Click OK.
To configure a MAC address using the CLI:
  1. Create a new MAC address:
    config firewall address
        edit "test-mac-addr1"
            set type mac
            set macaddr 00:0c:29:41:98:88
        next
    end
  2. Apply the address type to a policy. In transparent mode or the virtual wire pair interface, this address type can be mixed with other address types in the policy:
    config firewall policy
        edit 1
            set srcintf "port2"
            set dstintf "port1"
            set srcaddr "test-mac-addr1" "10-1-100-42"
            set dstaddr "all"
            set action accept
            set schedule "always"
            set service "ALL"
            set logtraffic all
            set nat enable
        next
    end