Fortinet black logo

CLI Reference

config firewall central-snat-map

config firewall central-snat-map

Configure central SNAT policies.

config firewall central-snat-map
    Description: Configure central SNAT policies.
    edit <policyid>
        set status [enable|disable]
        set action [bypass|masquerade|...]
        set ipv6 [enable|disable]
        set srcintf {string}
        set dstintf {string}
        config src-addr
            Description: Original source address.
            edit <name>
            next
        end
        config dst-addr
            Description: Destination address name from available addresses.
            edit <name>
            next
        end
        config nat-ippool
            Description: Name of the IP pools to be used to translate addresses from available IP Pools.
            edit <name>
            next
        end
        config src-addr6
            Description: Original IPV6 source address.
            edit <name>
            next
        end
        config dst-addr6
            Description: Destination address.
            edit <name>
            next
        end
        config nat-ippool6
            Description: IPv6 pool names for translated address.
            edit <name>
            next
        end
    next
end

config firewall central-snat-map

Parameter

Description

Type

Size

policyid

Policy ID.

integer

Minimum value: 0 Maximum value: 4294967295

status

Enable/disable the active status of this policy.

option

-

Option

Description

enable

Enable this policy.

disable

Disable this policy.

action

central SNAT action.

option

-

Option

Description

bypass

Bypass and do not perform NAT.

masquerade

NAT using the primary IP of destination interface.

ippool

NAT using ip pool.

ipv6

Enable/disable IPv6.

option

-

Option

Description

enable

Enable ipv6.

disable

Disable ipv6.

srcintf

Source interface name from available interfaces.

string

Maximum length: 35

dstintf

Destination interface name from available interfaces.

string

Maximum length: 35

config src-addr

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config dst-addr

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config nat-ippool

Parameter

Description

Type

Size

name

IP pool name.

string

Maximum length: 64

config src-addr6

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config dst-addr6

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config nat-ippool6

Parameter

Description

Type

Size

name

IP pool name.

string

Maximum length: 64

config firewall central-snat-map

Configure central SNAT policies.

config firewall central-snat-map
    Description: Configure central SNAT policies.
    edit <policyid>
        set status [enable|disable]
        set action [bypass|masquerade|...]
        set ipv6 [enable|disable]
        set srcintf {string}
        set dstintf {string}
        config src-addr
            Description: Original source address.
            edit <name>
            next
        end
        config dst-addr
            Description: Destination address name from available addresses.
            edit <name>
            next
        end
        config nat-ippool
            Description: Name of the IP pools to be used to translate addresses from available IP Pools.
            edit <name>
            next
        end
        config src-addr6
            Description: Original IPV6 source address.
            edit <name>
            next
        end
        config dst-addr6
            Description: Destination address.
            edit <name>
            next
        end
        config nat-ippool6
            Description: IPv6 pool names for translated address.
            edit <name>
            next
        end
    next
end

config firewall central-snat-map

Parameter

Description

Type

Size

policyid

Policy ID.

integer

Minimum value: 0 Maximum value: 4294967295

status

Enable/disable the active status of this policy.

option

-

Option

Description

enable

Enable this policy.

disable

Disable this policy.

action

central SNAT action.

option

-

Option

Description

bypass

Bypass and do not perform NAT.

masquerade

NAT using the primary IP of destination interface.

ippool

NAT using ip pool.

ipv6

Enable/disable IPv6.

option

-

Option

Description

enable

Enable ipv6.

disable

Disable ipv6.

srcintf

Source interface name from available interfaces.

string

Maximum length: 35

dstintf

Destination interface name from available interfaces.

string

Maximum length: 35

config src-addr

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config dst-addr

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config nat-ippool

Parameter

Description

Type

Size

name

IP pool name.

string

Maximum length: 64

config src-addr6

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config dst-addr6

Parameter

Description

Type

Size

name

Address name.

string

Maximum length: 64

config nat-ippool6

Parameter

Description

Type

Size

name

IP pool name.

string

Maximum length: 64