Fortinet black logo

Administration Guide

Renaming IPsec tunnels NEW

Renaming IPsec tunnels NEW

IPsec tunnels can be renamed. When you rename an IPsec tunnel, all references to the tunnel, such as routing and policies, are automatically updated to reflect the new name.

config vpn ipsec phase1-interface
    rename <string> to <string>
end

In this example, the IPsec tunnel named tofgtd is renamed to tofgtd-New, and all associated references are updated.

To rename an IPsec tunnel in the GUI:
  1. Go to VPN > IPsec Tunnels and double-click an IPsec tunnel to open it for editing.

    In this example, the IPsec tunnel name is tofgtd.

  2. In the Name box, type a new name, and click OK. The IPsec tunnel is renamed, and all associated references are updated.

    In this example, the IPsec tunnel is renamed to tofgtd-New.

  3. Check the associated references:

    In this example, all associated references show the new IPsec tunnel name of tofgtd-New.

    • Go to Network > Interfaces to see that the interface references the new IPsec tunnel name.

    • Go to Network > Static Routes to see that the static route references the new IPsec tunnel name.

    • Go to Policy & Objects > Firewall Policy to see that the policy references the new IPsec tunnel name

To rename an IPsec tunnel in the CLI:
  1. Rename the IPsec tunnel.

    In this example, the IPsec tunnel named tofgtd is renamed to tofgtd-New:

    config vpn ipsec phase1-interface
        rename tofgtd to tofgtd-New
    end
  2. Show the configuration to confirm that the IPsec tunnel was renamed.

    In this example, the IPsec tunnel was renamed to tofgtd-New:

    show 
    config vpn ipsec phase1-interface
        edit "tofgtd-New"
            set interface "port3"
            set peertype any
            set net-device disable
            set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
            set dpd disable
            set remote-gw 173.1.1.1
            ...
        next
    end
  3. Check the associated references.

    In this example, all associated references show the new IPsec tunnel name of tofgtd-New.

    • Confirm that the interfaces reference the new IPsec tunnel name:

      config router static 
      show
      config router static
          edit 3
              set dst 192.168.5.0 255.255.255.0
              set device "tofgtd-New"
          next
      end
    • Confirm that the static route references the new IPsec tunnel name:

      config system interface 
      show
          edit "tofgtd-New"
          ....
      end
    • Confirm that the policies references the new IPsec tunnel name:

      config firewall policy 
      show
      config firewall policy
          edit 1
              set uuid 802c6c2e-8368-51ee-bf40-6c3c32da1024
              set srcintf "port2"
              set dstintf "tofgtd-New"
              set action accept
              ...
          next
          edit 2
              set uuid 80d136aa-8368-51ee-cc52-b0b06306fb80
              set srcintf "tofgtd-New"
              set dstintf "port2"
              set action accept
              ...
          next
      end

Renaming IPsec tunnels NEW

IPsec tunnels can be renamed. When you rename an IPsec tunnel, all references to the tunnel, such as routing and policies, are automatically updated to reflect the new name.

config vpn ipsec phase1-interface
    rename <string> to <string>
end

In this example, the IPsec tunnel named tofgtd is renamed to tofgtd-New, and all associated references are updated.

To rename an IPsec tunnel in the GUI:
  1. Go to VPN > IPsec Tunnels and double-click an IPsec tunnel to open it for editing.

    In this example, the IPsec tunnel name is tofgtd.

  2. In the Name box, type a new name, and click OK. The IPsec tunnel is renamed, and all associated references are updated.

    In this example, the IPsec tunnel is renamed to tofgtd-New.

  3. Check the associated references:

    In this example, all associated references show the new IPsec tunnel name of tofgtd-New.

    • Go to Network > Interfaces to see that the interface references the new IPsec tunnel name.

    • Go to Network > Static Routes to see that the static route references the new IPsec tunnel name.

    • Go to Policy & Objects > Firewall Policy to see that the policy references the new IPsec tunnel name

To rename an IPsec tunnel in the CLI:
  1. Rename the IPsec tunnel.

    In this example, the IPsec tunnel named tofgtd is renamed to tofgtd-New:

    config vpn ipsec phase1-interface
        rename tofgtd to tofgtd-New
    end
  2. Show the configuration to confirm that the IPsec tunnel was renamed.

    In this example, the IPsec tunnel was renamed to tofgtd-New:

    show 
    config vpn ipsec phase1-interface
        edit "tofgtd-New"
            set interface "port3"
            set peertype any
            set net-device disable
            set proposal aes128-sha256 aes256-sha256 aes128-sha1 aes256-sha1
            set dpd disable
            set remote-gw 173.1.1.1
            ...
        next
    end
  3. Check the associated references.

    In this example, all associated references show the new IPsec tunnel name of tofgtd-New.

    • Confirm that the interfaces reference the new IPsec tunnel name:

      config router static 
      show
      config router static
          edit 3
              set dst 192.168.5.0 255.255.255.0
              set device "tofgtd-New"
          next
      end
    • Confirm that the static route references the new IPsec tunnel name:

      config system interface 
      show
          edit "tofgtd-New"
          ....
      end
    • Confirm that the policies references the new IPsec tunnel name:

      config firewall policy 
      show
      config firewall policy
          edit 1
              set uuid 802c6c2e-8368-51ee-bf40-6c3c32da1024
              set srcintf "port2"
              set dstintf "tofgtd-New"
              set action accept
              ...
          next
          edit 2
              set uuid 80d136aa-8368-51ee-cc52-b0b06306fb80
              set srcintf "tofgtd-New"
              set dstintf "port2"
              set action accept
              ...
          next
      end