Fortinet Document Library

Version:

Version:

Version:


Table of Contents

Administration Guide

Download PDF
Copy Link

FortiExtender models with two modems

FortiExtender models such as the FEX-202E and FEX-212E have two modems. Both modems can be configured so virtual interfaces can be associated to them. The following example uses an FEX-212E.

To configure the FortiExtender in the GUI:
  1. Configure the two modems:
    1. Go to Network > FortiExtender and in the top menu, click Extenders.
    2. Double-click the device to edit the settings.
    3. In the State section, ensure the Authorized toggle is enabled.
    4. In the Modem 1 section, in Interface dropdown, click + Create.
    5. Enter a name and configure the other settings as needed.
    6. Click OK.
    7. In the Interface dropdown, select the newly created interface.
    8. Repeat these steps for the Modem 2 section.

      The FortiExtender now provides two virtual interfaces (fext and fext2) that will be used in the virtual WAN link interface.

  2. In the right panel, click Diagnostics and Tools to view more details:
    1. Click Modems to review the modem status.

    2. Click SIM Status to review the SIM status.

  3. Configure the virtual WAN link:
    1. Go to Network > SD-WAN, select SD-WAN Zones tab, and click Create New > SD-WAN Member.
    2. For Interface, select the modem 1 interface (fext) and ensure the Status is enabled.
    3. Click OK.
    4. Repeat these steps for the modem 2 interface (fext2).
  4. Configure the default static route:
    1. Go to Network > Static Routes and edit the 0.0.0.0/0 route.
    2. For Interface, select SD-WAN.
    3. Ensure the Status is enabled.
    4. Click OK.
  5. Configure the firewall policy:
    1. Go to Policy & Objects > Firewall Policy and click Create New.
    2. For Outgoing Interface, select virtual-wan-link.
    3. Configure the other settings as needed.
    4. Click OK.
To configure the FortiExtender in the CLI:
  1. Configure the two modems:
    config extender-controller extender
        edit "FX212E5919000000"
            set id "FX212E5919000000"
            set authorized enable
            config modem1
                set ifname "fext"
                config auto-switch
                    set disconnect enable
                    set signal enable
                    set dataplan enable
                    set switch-back-time "0:1 "
                end
            end
            config modem2
                set ifname "fext2"
                config auto-switch
                    set dataplan enable
                    set switch-back-time "0:1 "
                end
            end
        next
    end

    The FortiExtender now provides two virtual interfaces (fext and fext2) that will be used in the virtual WAN link interface.

  2. Verify the modem settings:
    get extender modem-status FX212E5919000000 1
    Modem 0:
        physical_port:       2-1.2
        manufacture:         Sierra Wireless, Incorporated
        product:             Sierra Wireless, Incorporated
        ....
  3. Configure the virtual WAN link:
    config system sdwan
        set status enable
        config zone
            edit "virtual-wan-link"
            next
        end
        config members
            edit 1
                set interface "fext"
            next
            edit 2
                set interface "fext2"
            next
        end
    end
  4. Configure the default static route:
    config router static
        edit 2
            set distance 1
            set sdwan enable
        next
    end
  5. Configure the firewall policy:
    config firewall policy
        edit 1
            set name "fext-traffic"
            set srcintf "wan1"
            set dstintf "virtual-wan-link"
            set srcaddr "all"
            set dstaddr "all"
            set action accept
            set schedule "always"
            set service "ALL"
            set nat enable
        next
    end

FortiExtender models with two modems

FortiExtender models such as the FEX-202E and FEX-212E have two modems. Both modems can be configured so virtual interfaces can be associated to them. The following example uses an FEX-212E.

To configure the FortiExtender in the GUI:
  1. Configure the two modems:
    1. Go to Network > FortiExtender and in the top menu, click Extenders.
    2. Double-click the device to edit the settings.
    3. In the State section, ensure the Authorized toggle is enabled.
    4. In the Modem 1 section, in Interface dropdown, click + Create.
    5. Enter a name and configure the other settings as needed.
    6. Click OK.
    7. In the Interface dropdown, select the newly created interface.
    8. Repeat these steps for the Modem 2 section.

      The FortiExtender now provides two virtual interfaces (fext and fext2) that will be used in the virtual WAN link interface.

  2. In the right panel, click Diagnostics and Tools to view more details:
    1. Click Modems to review the modem status.

    2. Click SIM Status to review the SIM status.

  3. Configure the virtual WAN link:
    1. Go to Network > SD-WAN, select SD-WAN Zones tab, and click Create New > SD-WAN Member.
    2. For Interface, select the modem 1 interface (fext) and ensure the Status is enabled.
    3. Click OK.
    4. Repeat these steps for the modem 2 interface (fext2).
  4. Configure the default static route:
    1. Go to Network > Static Routes and edit the 0.0.0.0/0 route.
    2. For Interface, select SD-WAN.
    3. Ensure the Status is enabled.
    4. Click OK.
  5. Configure the firewall policy:
    1. Go to Policy & Objects > Firewall Policy and click Create New.
    2. For Outgoing Interface, select virtual-wan-link.
    3. Configure the other settings as needed.
    4. Click OK.
To configure the FortiExtender in the CLI:
  1. Configure the two modems:
    config extender-controller extender
        edit "FX212E5919000000"
            set id "FX212E5919000000"
            set authorized enable
            config modem1
                set ifname "fext"
                config auto-switch
                    set disconnect enable
                    set signal enable
                    set dataplan enable
                    set switch-back-time "0:1 "
                end
            end
            config modem2
                set ifname "fext2"
                config auto-switch
                    set dataplan enable
                    set switch-back-time "0:1 "
                end
            end
        next
    end

    The FortiExtender now provides two virtual interfaces (fext and fext2) that will be used in the virtual WAN link interface.

  2. Verify the modem settings:
    get extender modem-status FX212E5919000000 1
    Modem 0:
        physical_port:       2-1.2
        manufacture:         Sierra Wireless, Incorporated
        product:             Sierra Wireless, Incorporated
        ....
  3. Configure the virtual WAN link:
    config system sdwan
        set status enable
        config zone
            edit "virtual-wan-link"
            next
        end
        config members
            edit 1
                set interface "fext"
            next
            edit 2
                set interface "fext2"
            next
        end
    end
  4. Configure the default static route:
    config router static
        edit 2
            set distance 1
            set sdwan enable
        next
    end
  5. Configure the firewall policy:
    config firewall policy
        edit 1
            set name "fext-traffic"
            set srcintf "wan1"
            set dstintf "virtual-wan-link"
            set srcaddr "all"
            set dstaddr "all"
            set action accept
            set schedule "always"
            set service "ALL"
            set nat enable
        next
    end