Fortinet black logo

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:

Version:


Table of Contents

CLI Reference

config router policy6

Configure IPv6 routing policies.

config router policy6

Description: Configure IPv6 routing policies.

edit <seq-num>

set input-device <name1>, <name2>, ...

set input-device-negate [enable|disable]

set src <addr61>, <addr62>, ...

set srcaddr <name1>, <name2>, ...

set src-negate [enable|disable]

set dst <addr61>, <addr62>, ...

set dstaddr <name1>, <name2>, ...

set dst-negate [enable|disable]

set action [deny|permit]

set protocol {integer}

set start-port {integer}

set end-port {integer}

set gateway {ipv6-address}

set output-device {string}

set tos {user}

set tos-mask {user}

set status [enable|disable]

set comments {var-string}

set internet-service-id <id1>, <id2>, ...

set internet-service-custom <name1>, <name2>, ...

next

end

config router policy6

Parameter

Description

Type

Size

Default

input-device <name>

Incoming interface name.

Interface name.

string

Maximum length: 79

input-device-negate

Enable/disable negation of input device match.

option

-

disable

 

Option

Description

enable

Enable negation of input device match.

disable

Disable negation of input device match.

src <addr6>

Source IPv6 prefix.

IPv6 address prefix.

string

Maximum length: 79

srcaddr <name>

Source address name.

Address/group name.

string

Maximum length: 79

src-negate

Enable/disable negating source address match.

option

-

disable

 

Option

Description

enable

Enable source address negation.

disable

Disable source address negation.

dst <addr6>

Destination IPv6 prefix.

IPv6 address prefix.

string

Maximum length: 79

dstaddr <name>

Destination address name.

Address/group name.

string

Maximum length: 79

dst-negate

Enable/disable negating destination address match.

option

-

disable

 

Option

Description

enable

Enable destination address negation.

disable

Disable destination address negation.

action

Action of the policy route.

option

-

permit

 

Option

Description

deny

Do not search policy route table.

permit

Use this policy route for forwarding.

protocol

Protocol number .

integer

Minimum value: 0 Maximum value: 255

0

start-port

Start destination port number .

integer

Minimum value: 1 Maximum value: 65535

1

end-port

End destination port number .

integer

Minimum value: 1 Maximum value: 65535

65535

gateway

IPv6 address of the gateway.

ipv6-address

Not Specified

::

output-device

Outgoing interface name.

string

Not Specified

tos

Type of service bit pattern.

user

Not Specified

tos-mask

Type of service evaluated bits.

user

Not Specified

status

Enable/disable this policy route.

option

-

enable

 

Option

Description

enable

Enable this policy route.

disable

Disable this policy route.

comments

Optional comments.

var-string

Not Specified

internet-service-id <id>

Destination Internet Service ID.

Destination Internet Service ID.

integer

Minimum value: 0 Maximum value: 4294967295

internet-service-custom <name>

Custom Destination Internet Service name.

Custom Destination Internet Service name.

string

Maximum length: 79

config router policy6

Configure IPv6 routing policies.

config router policy6

Description: Configure IPv6 routing policies.

edit <seq-num>

set input-device <name1>, <name2>, ...

set input-device-negate [enable|disable]

set src <addr61>, <addr62>, ...

set srcaddr <name1>, <name2>, ...

set src-negate [enable|disable]

set dst <addr61>, <addr62>, ...

set dstaddr <name1>, <name2>, ...

set dst-negate [enable|disable]

set action [deny|permit]

set protocol {integer}

set start-port {integer}

set end-port {integer}

set gateway {ipv6-address}

set output-device {string}

set tos {user}

set tos-mask {user}

set status [enable|disable]

set comments {var-string}

set internet-service-id <id1>, <id2>, ...

set internet-service-custom <name1>, <name2>, ...

next

end

config router policy6

Parameter

Description

Type

Size

Default

input-device <name>

Incoming interface name.

Interface name.

string

Maximum length: 79

input-device-negate

Enable/disable negation of input device match.

option

-

disable

 

Option

Description

enable

Enable negation of input device match.

disable

Disable negation of input device match.

src <addr6>

Source IPv6 prefix.

IPv6 address prefix.

string

Maximum length: 79

srcaddr <name>

Source address name.

Address/group name.

string

Maximum length: 79

src-negate

Enable/disable negating source address match.

option

-

disable

 

Option

Description

enable

Enable source address negation.

disable

Disable source address negation.

dst <addr6>

Destination IPv6 prefix.

IPv6 address prefix.

string

Maximum length: 79

dstaddr <name>

Destination address name.

Address/group name.

string

Maximum length: 79

dst-negate

Enable/disable negating destination address match.

option

-

disable

 

Option

Description

enable

Enable destination address negation.

disable

Disable destination address negation.

action

Action of the policy route.

option

-

permit

 

Option

Description

deny

Do not search policy route table.

permit

Use this policy route for forwarding.

protocol

Protocol number .

integer

Minimum value: 0 Maximum value: 255

0

start-port

Start destination port number .

integer

Minimum value: 1 Maximum value: 65535

1

end-port

End destination port number .

integer

Minimum value: 1 Maximum value: 65535

65535

gateway

IPv6 address of the gateway.

ipv6-address

Not Specified

::

output-device

Outgoing interface name.

string

Not Specified

tos

Type of service bit pattern.

user

Not Specified

tos-mask

Type of service evaluated bits.

user

Not Specified

status

Enable/disable this policy route.

option

-

enable

 

Option

Description

enable

Enable this policy route.

disable

Disable this policy route.

comments

Optional comments.

var-string

Not Specified

internet-service-id <id>

Destination Internet Service ID.

Destination Internet Service ID.

integer

Minimum value: 0 Maximum value: 4294967295

internet-service-custom <name>

Custom Destination Internet Service name.

Custom Destination Internet Service name.

string

Maximum length: 79